// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\w+?)(sin|in|pak|red)$").unwrap();
let string = "setesin";
let substitution = "$1tak";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}