$re = '/(\w+?)(sin|in|pak|red)$/';
$str = 'setesin';
$subst = "$1tak";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;