import re
regex = re.compile(r"(\w+?)(sin|in|pak|red)$")
test_str = "setesin"
subst = "$1tak"
result = regex.sub(subst, test_str)
if result:
print(result)