$re = '/(?<=<br>)\s*\R/';
$str = '<br>
No atraviesa el papel
<br>
No atraviesa el papel
<br>
No atraviesa el papel';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;