import re
regex = re.compile(r"(?<=<br>)\s*\R")
test_str = ("<br> \n\n\n"
"No atraviesa el papel\n\n"
"<br>\n"
"No atraviesa el papel\n\n"
"<br>\n"
"No atraviesa el papel")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)