#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\d{4}[a-zA-Z]{1}|\d{2}[.]\d{2}[a-zA-Z]{1})"
Local $sString = "Si vous êtes coiffeur, votre code APE est alors le 96.02A (le même que pour coiffeur-barbier)." & @CRLF & _
"" & @CRLF & _
"Si vous êtes chauffeur de VTC, votre code APE est le 49.32Z (le même que pour les taxis)." & @CRLF & _
"" & @CRLF & _
"Si vous êtes plombier, votre code APE est le 43.22A." & @CRLF & _
"" & @CRLF & _
"Si vous êtes électricien, votre code APE est le 43.21A."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")