use strict;
my $str = 'Si vous êtes coiffeur, votre code APE est alors le 96.02A (le même que pour coiffeur-barbier).
Si vous êtes chauffeur de VTC, votre code APE est le 49.32Z (le même que pour les taxis).
Si vous êtes plombier, votre code APE est le 43.22A.
Si vous êtes électricien, votre code APE est le 43.21A.';
my $regex = qr/(\d{4}[a-zA-Z]{1}|\d{2}[.]\d{2}[a-zA-Z]{1})/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}