import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{4}[a-zA-Z]{1}|\\d{2}[.]\\d{2}[a-zA-Z]{1})";
final String string = "Si vous êtes coiffeur, votre code APE est alors le 96.02A (le même que pour coiffeur-barbier).\n\n"
+ "Si vous êtes chauffeur de VTC, votre code APE est le 49.32Z (le même que pour les taxis).\n\n"
+ "Si vous êtes plombier, votre code APE est le 43.22A.\n\n"
+ "Si vous êtes électricien, votre code APE est le 43.21A.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}