using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{4}[a-zA-Z]{1}|\d{2}[.]\d{2}[a-zA-Z]{1})";
string input = @"Si vous êtes coiffeur, votre code APE est alors le 96.02A (le même que pour coiffeur-barbier).
Si vous êtes chauffeur de VTC, votre code APE est le 49.32Z (le même que pour les taxis).
Si vous êtes plombier, votre code APE est le 43.22A.
Si vous êtes électricien, votre code APE est le 43.21A.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}