$re = '/(\d{4}[a-zA-Z]{1}|\d{2}[.]\d{2}[a-zA-Z]{1})/';
$str = 'Si vous êtes coiffeur, votre code APE est alors le 96.02A (le même que pour coiffeur-barbier).
Si vous êtes chauffeur de VTC, votre code APE est le 49.32Z (le même que pour les taxis).
Si vous êtes plombier, votre code APE est le 43.22A.
Si vous êtes électricien, votre code APE est le 43.21A.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);