package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d{4}[a-zA-Z]{1}|\d{2}[.]\d{2}[a-zA-Z]{1})`)
var str = `Si vous êtes coiffeur, votre code APE est alors le 96.02A (le même que pour coiffeur-barbier).
Si vous êtes chauffeur de VTC, votre code APE est le 49.32Z (le même que pour les taxis).
Si vous êtes plombier, votre code APE est le 43.22A.
Si vous êtes électricien, votre code APE est le 43.21A.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}