// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\d{4}[a-zA-Z]{1}|\d{2}[.]\d{2}[a-zA-Z]{1})").unwrap();
let string = "Si vous êtes coiffeur, votre code APE est alors le 96.02A (le même que pour coiffeur-barbier).
Si vous êtes chauffeur de VTC, votre code APE est le 49.32Z (le même que pour les taxis).
Si vous êtes plombier, votre code APE est le 43.22A.
Si vous êtes électricien, votre code APE est le 43.21A.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}