const regex = /[?&]ordem=\d+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[?&]ordem=\\d+', 'gm')
const str = `http://www.meudominio.com.br/pagina.php?campo=teste&cor=azul&ordem=2
http://www.meudominio.com.br/pagina.php?campo=teste&ordem=2&cor=azul
http://www.meudominio.com.br/pagina.php?ordem=2&campo=teste&cor=azul`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);