import Foundation
let pattern = #"[?&]ordem=\d+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http://www.meudominio.com.br/pagina.php?campo=teste&cor=azul&ordem=2
http://www.meudominio.com.br/pagina.php?campo=teste&ordem=2&cor=azul
http://www.meudominio.com.br/pagina.php?ordem=2&campo=teste&cor=azul
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)