$re = '/[?&]ordem=\d+/m';
$str = 'http://www.meudominio.com.br/pagina.php?campo=teste&cor=azul&ordem=2
http://www.meudominio.com.br/pagina.php?campo=teste&ordem=2&cor=azul
http://www.meudominio.com.br/pagina.php?ordem=2&campo=teste&cor=azul';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;