#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!^([0-9]+([èe]?r)?e )?)Avenue"
Local $sString = "Avenue du Domaine-Patry (fr)" & @CRLF & _
"1ère Avenue du Domaine-Patry (fr)" & @CRLF & _
"1re Avenue du Domaine-Patry (fr)" & @CRLF & _
"1e Avenue du Domaine-Patry (fr)" & @CRLF & _
"1st Avenue du Domaine-Patry (en)" & @CRLF & _
"101th Avenue du Domaine-Patry (en)" & @CRLF & _
"Domaine-Patry Avenue (en)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")