re = /(?<!^([0-9]+([èe]?r)?e )?)Avenue/m
str = 'Avenue du Domaine-Patry (fr)
1ère Avenue du Domaine-Patry (fr)
1re Avenue du Domaine-Patry (fr)
1e Avenue du Domaine-Patry (fr)
1st Avenue du Domaine-Patry (en)
101th Avenue du Domaine-Patry (en)
Domaine-Patry Avenue (en)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end