import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!^([0-9]+([èe]?r)?e )?)Avenue";
final String string = "Avenue du Domaine-Patry (fr)\n"
+ "1ère Avenue du Domaine-Patry (fr)\n"
+ "1re Avenue du Domaine-Patry (fr)\n"
+ "1e Avenue du Domaine-Patry (fr)\n"
+ "1st Avenue du Domaine-Patry (en)\n"
+ "101th Avenue du Domaine-Patry (en)\n"
+ "Domaine-Patry Avenue (en)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}