using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!^([0-9]+([èe]?r)?e )?)Avenue";
string input = @"Avenue du Domaine-Patry (fr)
1ère Avenue du Domaine-Patry (fr)
1re Avenue du Domaine-Patry (fr)
1e Avenue du Domaine-Patry (fr)
1st Avenue du Domaine-Patry (en)
101th Avenue du Domaine-Patry (en)
Domaine-Patry Avenue (en)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}