import re
regex = re.compile(r"(?<!^([0-9]+([èe]?r)?e )?)Avenue", flags=re.MULTILINE)
test_str = ("Avenue du Domaine-Patry (fr)\n"
"1ère Avenue du Domaine-Patry (fr)\n"
"1re Avenue du Domaine-Patry (fr)\n"
"1e Avenue du Domaine-Patry (fr)\n"
"1st Avenue du Domaine-Patry (en)\n"
"101th Avenue du Domaine-Patry (en)\n"
"Domaine-Patry Avenue (en)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")