use strict;
my $str = 'Avenue du Domaine-Patry (fr)
1ère Avenue du Domaine-Patry (fr)
1re Avenue du Domaine-Patry (fr)
1e Avenue du Domaine-Patry (fr)
1st Avenue du Domaine-Patry (en)
101th Avenue du Domaine-Patry (en)
Domaine-Patry Avenue (en)';
my $regex = qr/(?<!^([0-9]+([èe]?r)?e )?)Avenue/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}