$re = '/(?<!^([0-9]+([èe]?r)?e )?)Avenue/m';
$str = 'Avenue du Domaine-Patry (fr)
1ère Avenue du Domaine-Patry (fr)
1re Avenue du Domaine-Patry (fr)
1e Avenue du Domaine-Patry (fr)
1st Avenue du Domaine-Patry (en)
101th Avenue du Domaine-Patry (en)
Domaine-Patry Avenue (en)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);