const regex = /(?<!^([0-9]+([èe]?r)?e )?)Avenue/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!^([0-9]+([èe]?r)?e )?)Avenue', 'gm')
const str = `Avenue du Domaine-Patry (fr)
1ère Avenue du Domaine-Patry (fr)
1re Avenue du Domaine-Patry (fr)
1e Avenue du Domaine-Patry (fr)
1st Avenue du Domaine-Patry (en)
101th Avenue du Domaine-Patry (en)
Domaine-Patry Avenue (en)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}