#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "https://([a-z0-9]+\.)*storyblok\.com(:[0-9]+)?(\\/[^?#]*)?([?][^#]*)?"
Local $sString = "https://a-us.storyblok.com/f/1003691/2732x2632/fca4f13694/alpaca-bw.png"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")