use strict;
my $str = 'https://a-us.storyblok.com/f/1003691/2732x2632/fca4f13694/alpaca-bw.png';
my $regex = qr`https://([a-z0-9]+\.)*storyblok\.com(:[0-9]+)?(\\/[^?#]*)?([?][^#]*)?`p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}