// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"https://([a-z0-9]+\.)*storyblok\.com(:[0-9]+)?(\\/[^?#]*)?([?][^#]*)?").unwrap();
let string = "https://a-us.storyblok.com/f/1003691/2732x2632/fca4f13694/alpaca-bw.png";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}