const regex = new RegExp('https://([a-z0-9]+\\.)*storyblok\\.com(:[0-9]+)?(\\\\/[^?#]*)?([?][^#]*)?', '')
const str = `https://a-us.storyblok.com/f/1003691/2732x2632/fca4f13694/alpaca-bw.png`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}