$re = '`https://([a-z0-9]+\.)*storyblok\.com(:[0-9]+)?(\\\\/[^?#]*)?([?][^#]*)?`';
$str = 'https://a-us.storyblok.com/f/1003691/2732x2632/fca4f13694/alpaca-bw.png';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);