import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https://([a-z0-9]+\\.)*storyblok\\.com(:[0-9]+)?(\\\\/[^?#]*)?([?][^#]*)?";
final String string = "https://a-us.storyblok.com/f/1003691/2732x2632/fca4f13694/alpaca-bw.png";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}