package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`https://([a-z0-9]+\.)*storyblok\.com(:[0-9]+)?(\\/[^?#]*)?([?][^#]*)?`)
var str = `https://a-us.storyblok.com/f/1003691/2732x2632/fca4f13694/alpaca-bw.png`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}