using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https://([a-z0-9]+\.)*storyblok\.com(:[0-9]+)?(\\/[^?#]*)?([?][^#]*)?";
string input = @"https://a-us.storyblok.com/f/1003691/2732x2632/fca4f13694/alpaca-bw.png";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}