#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(.*?[^a-z\r\n])?((cat|dog)s?)([^a-z\r\n].*?)?$"
Local $sString = "A likes cat pics" & @CRLF & _
"B likes Cats" & @CRLF & _
"I adore !!cats!!" & @CRLF & _
"H likes cat; he has four of them." & @CRLF & _
"F is catholic" & @CRLF & _
"D likes cat!" & @CRLF & _
"cat" & @CRLF & _
"cats" & @CRLF & _
"hello" & @CRLF & _
"x likes dogs, he has three of them." & @CRLF & _
"x is dogmatic" & @CRLF & _
"dog"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")