re = /^(.*?[^a-z\r\n])?((cat|dog)s?)([^a-z\r\n].*?)?$/mi
str = 'A likes cat pics
B likes Cats
I adore !!cats!!
H likes cat; he has four of them.
F is catholic
D likes cat!
cat
cats
hello
x likes dogs, he has three of them.
x is dogmatic
dog'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end