$re = '/^(.*?[^a-z\r\n])?((cat|dog)s?)([^a-z\r\n].*?)?$/mi';
$str = 'A likes cat pics
B likes Cats
I adore !!cats!!
H likes cat; he has four of them.
F is catholic
D likes cat!
cat
cats
hello
x likes dogs, he has three of them.
x is dogmatic
dog';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);