import re
regex = re.compile(r"^(.*?[^a-z\r\n])?((cat|dog)s?)([^a-z\r\n].*?)?$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("A likes cat pics\n"
"B likes Cats\n"
"I adore !!cats!!\n"
"H likes cat; he has four of them.\n"
"F is catholic\n"
"D likes cat!\n"
"cat\n"
"cats\n"
"hello\n"
"x likes dogs, he has three of them.\n"
"x is dogmatic\n"
"dog")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")