import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*?[^a-z\\r\\n])?((cat|dog)s?)([^a-z\\r\\n].*?)?$";
final String string = "A likes cat pics\n"
+ "B likes Cats\n"
+ "I adore !!cats!!\n"
+ "H likes cat; he has four of them.\n"
+ "F is catholic\n"
+ "D likes cat!\n"
+ "cat\n"
+ "cats\n"
+ "hello\n"
+ "x likes dogs, he has three of them.\n"
+ "x is dogmatic\n"
+ "dog";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}