const regex = new RegExp('^(.*?[^a-z\\r\\n])?((cat|dog)s?)([^a-z\\r\\n].*?)?$', 'gmi')
const str = `A likes cat pics
B likes Cats
I adore !!cats!!
H likes cat; he has four of them.
F is catholic
D likes cat!
cat
cats
hello
x likes dogs, he has three of them.
x is dogmatic
dog`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}