using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=key=\""([^\""]+)\"".*)\1|(?=.*key=\""([^\""]+)\"".*)\2";
string substitution = @"***";
string input = @"name=""prefix1 - key_string suffix1"" displayName=""prefix1 - key_string suffix2"" key=""key_string"" name2=""prefix2 - key_string suffix1"" desc=""prefix1 - key_string suffix1";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}