use strict;
my $str = 'name="prefix1 - key_string suffix1" displayName="prefix1 - key_string suffix2" key="key_string" name2="prefix2 - key_string suffix1" desc="prefix1 - key_string suffix1';
my $regex = qr/(?<=key=\"([^\"]+)\".*)\1|(?=.*key=\"([^\"]+)\".*)\2/mp;
my $subst = '***';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";