import Foundation
let pattern = #"(?<=key=\"([^\"]+)\".*)\1|(?=.*key=\"([^\"]+)\".*)\2"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"name="prefix1 - key_string suffix1" displayName="prefix1 - key_string suffix2" key="key_string" name2="prefix2 - key_string suffix1" desc="prefix1 - key_string suffix1"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"***"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)