const regex = new RegExp('(?<=key=\\"([^\\"]+)\\".*)\\1|(?=.*key=\\"([^\\"]+)\\".*)\\2', 'gm')
const str = `name="prefix1 - key_string suffix1" displayName="prefix1 - key_string suffix2" key="key_string" name2="prefix2 - key_string suffix1" desc="prefix1 - key_string suffix1`;
const subst = `***`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);