re = /(?<=key=\"([^\"]+)\".*)\1|(?=.*key=\"([^\"]+)\".*)\2/m
str = 'name="prefix1 - key_string suffix1" displayName="prefix1 - key_string suffix2" key="key_string" name2="prefix2 - key_string suffix1" desc="prefix1 - key_string suffix1'
subst = '***'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result