import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=key=\\\"([^\\\"]+)\\\".*)\\1|(?=.*key=\\\"([^\\\"]+)\\\".*)\\2";
final String string = "name=\"prefix1 - key_string suffix1\" displayName=\"prefix1 - key_string suffix2\" key=\"key_string\" name2=\"prefix2 - key_string suffix1\" desc=\"prefix1 - key_string suffix1";
final String subst = "***";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}