import re
regex = re.compile(r"(?<=key=\"([^\"]+)\".*)\1|(?=.*key=\"([^\"]+)\".*)\2", flags=re.MULTILINE)
test_str = "name=\"prefix1 - key_string suffix1\" displayName=\"prefix1 - key_string suffix2\" key=\"key_string\" name2=\"prefix2 - key_string suffix1\" desc=\"prefix1 - key_string suffix1"
subst = "***"
result = regex.sub(subst, test_str)
if result:
print(result)