# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[(.+?)\]\(((?:https?:)?(\\/|\\)\3(?:www\.)?.+?\.[a-z]+\3)\)/<a href="$2">$1<\/a>/g;t' <<< "This [is a](https://google.com/) text.
This [is a](https://www.google.com/) text.
This [is a](http://google.com/) text.
This [is a](https:\\google.com\) text.
This [is a](//google.com/) text.
This [is a](https://google./) text.
This [is a](https://.com/) text.
This [is a](https://googlecom/) text.
This [is a](https://google.com) text."