using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(.+?)\]\(((?:https?:)?(\/|\\)\3(?:www\.)?.+?\.[a-z]+\3)\)";
string substitution = @"<a href=""$2"">$1</a>";
string input = @"This [is a](https://google.com/) text.
This [is a](https://www.google.com/) text.
This [is a](http://google.com/) text.
This [is a](https:\\google.com\) text.
This [is a](//google.com/) text.
This [is a](https://google./) text.
This [is a](https://.com/) text.
This [is a](https://googlecom/) text.
This [is a](https://google.com) text.";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}