#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\[(.+?)\]\(((?:https?:)?(\/|\\)\3(?:www\.)?.+?\.[a-z]+\3)\)"
Local $sString = "This [is a](https://google.com/) text." & @CRLF & _
"This [is a](https://www.google.com/) text." & @CRLF & _
"This [is a](http://google.com/) text." & @CRLF & _
"This [is a](https:\\google.com\) text." & @CRLF & _
"This [is a](//google.com/) text." & @CRLF & _
"" & @CRLF & _
"This [is a](https://google./) text." & @CRLF & _
"This [is a](https://.com/) text." & @CRLF & _
"This [is a](https://googlecom/) text." & @CRLF & _
"This [is a](https://google.com) text."
Local $sSubst = "<a href="$2">$1</a>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)