const regex = /\[(.+?)\]\(((?:https?:)?(\/|\\)\3(?:www\.)?.+?\.[a-z]+\3)\)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[(.+?)\\]\\(((?:https?:)?(\\\/|\\\\)\\3(?:www\\.)?.+?\\.[a-z]+\\3)\\)', 'g')
const str = `This [is a](https://google.com/) text.
This [is a](https://www.google.com/) text.
This [is a](http://google.com/) text.
This [is a](https:\\\\google.com\\) text.
This [is a](//google.com/) text.
This [is a](https://google./) text.
This [is a](https://.com/) text.
This [is a](https://googlecom/) text.
This [is a](https://google.com) text.`;
const subst = `<a href="$2">$1</a>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);