import Foundation
let pattern = #"\[(.+?)\]\(((?:https?:)?(\/|\\)\3(?:www\.)?.+?\.[a-z]+\3)\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
This [is a](https://google.com/) text.
This [is a](https://www.google.com/) text.
This [is a](http://google.com/) text.
This [is a](https:\\google.com\) text.
This [is a](//google.com/) text.
This [is a](https://google./) text.
This [is a](https://.com/) text.
This [is a](https://googlecom/) text.
This [is a](https://google.com) text.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<a href="$2">$1</a>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)