import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[(.+?)\\]\\(((?:https?:)?(\\/|\\\\)\\3(?:www\\.)?.+?\\.[a-z]+\\3)\\)";
final String string = "This [is a](https://google.com/) text.\n"
+ "This [is a](https://www.google.com/) text.\n"
+ "This [is a](http://google.com/) text.\n"
+ "This [is a](https:\\\\google.com\\) text.\n"
+ "This [is a](//google.com/) text.\n\n"
+ "This [is a](https://google./) text.\n"
+ "This [is a](https://.com/) text.\n"
+ "This [is a](https://googlecom/) text.\n"
+ "This [is a](https://google.com) text.";
final String subst = "<a href=\"$2\">$1</a>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}